Domaines
RH
Juridique
Compta
Administratif/Moyens Généraux
Communication
Bureautique
Conseils aux débutants
Word
Excel
PowerPoint
Outlook
Access
Publisher
Windows/système
Applications pas à pas
Tests logiciels
Macros VBA
Leçons
Macros Word
Macros Excel
Astuces
Orthographe
Rédaction
Organisation
 
Outils
Ouvrages
Modèles
Macros
 
Anglais
Grammaire avec AnglaisFacile
Leçon gratuite avec AnglaisFacile
Carrière
Gestion de carrière
Fiches métier
Témoignages / vécu
 
 

Echanger

Forums

© Nadège Guilbert
Le contenu de ce site
est régulièrement déposé auprès de la SGDL
Reproduction interdite
sans le consentement
écrit de l'auteur



Imprimer la page

Bureautique > Excel

04-Jan-2004

 

 

Traiter des nombres
Calculer des pourcentages
Les formules "Si", "Et", "Ou"
Calculs conditionnels : nb.Si
Calculs conditionnels : somme.si
Cumuler les conditions nb.si

traiter du texte
Concaténer des chaînes : &
Majuscule / Minuscule / NomPropre

Les formules "Si", "Et", "ou"

La formule "Si" est l'une des formules d'Excel les plus faciles à appréhender... après SOMME() !

Pour tirer pleinement parti de cette fonction et la doper, n'hésitez pas à la combiner avec les formules "Et" et "ou" que nous allons donc aborder conjointement.

La syntaxe de la formule SI est la suivante :

=SI(ma condition; réponse ou action si vraie ;
réponse ou action si faux)

Prenons un exemple : le carnet de notes de Théodule, (à télécharger). Ce document comprend une feuille "Exercice" et une feuille "Solution". Si vous pensez bien connaître Excel, privilégiez la première et ne vous reportez à cette leçon qu'en cas d'erreur.

Nous allons nous intéresser à ses performances en langues afin de savoir s'il est particulièrement doué dans cette matière et tenter de traduire ces conditions en langage Excel.

Voici les résultats de Théo en langues (Moyenne 14,75):

Langues

Notes

Anglais

18

2e langue

11,5

Nous allons donc tenter de vérifier si Théo mérite de faire une carrière de traducteur. Si la réponse aux conditions suivantes est vraie, nous souhaiterions qu'Excel nous l'indique en saisissant "Doué"et, dans le cas contraire, en entrant "Pas doué". Allons-y !

1er cas : Théo est considéré comme "doué" si sa moyenne en langues est supérieure ou égale à 14

On pourrait traduire, de façon intermédiaire, par la syntaxe suivante : si moyenne(anglais+2e langue)>=14 alors "Doué", sinon "Pas doué"

Dans notre tableau, la formule correspondante est donc :

=SI(MOYENNE(B10+B12)>=14;"Doué";"Pas doué")

Vous suivez ? Continuons...

Haut

Niveau

Pré-requis :

  • Aucun