Domaines
RH
Juridique
Compta
Administratif/Moyens Généraux
Communication
Bureautique
Conseils aux débutants
Word
Excel
PowerPoint
Outlook
Access
Publisher
Windows/système
Applications pas à pas
Tests logiciels
Macros VBA
Leçons
Macros Word
Macros Excel
Astuces
Orthographe
Rédaction
Organisation
 
Outils
Ouvrages
Modèles
Macros
 
Anglais
Grammaire avec AnglaisFacile
Leçon gratuite avec AnglaisFacile
Carrière
Gestion de carrière
Fiches métier
Témoignages / vécu
 
 

Echanger

Forums

© Nadège Guilbert
Le contenu de ce site
est régulièrement déposé auprès de la SGDL
Reproduction interdite
sans le consentement
écrit de l'auteur

Imprimer la page

Bureautique > Excel

04-Jan-2004

 

 

Traiter des nombres
Calculer des pourcentages
Les formules "Si", "Et", "Ou"
Calculs conditionnels : nb.Si
Calculs conditionnels : somme.si
Cumuler les conditions nb.si

traiter du texte
Concaténer des chaînes : &
Majuscule / Minuscule / NomPropre

Additionner des données répondant à un critère : Somme.si


Nous avons vu dans la leçon précédente que la fonction nb.si nous permettait de compter le nombre d'éléments d'un tableau répondant à un critère donné.

Imaginons maintenant que vous voulions connaître le montant du CA réalisé par chacun de nos vendeurs. Encore une fois, ce problème peut-être rapidement résolu grâce à une formule conditionnelle : somme.si.

La formule somme.si prend 3 arguments : plage à analyser (celle que nous avons nommée "monTableau" dans la leçon précédente) ; critère (l'élément recherché, autrement dit "Pierre", pour la première ligne de notre tableau) ; [somme_plage] (la zone à additionner, c'est-à-dire B4 à B26 dans notre exemple)

Notre formule finale sera donc =somme.si(monTableau ; D3 ; B4:B26).

Attention ! Si vous souhaitez recopier cette formule dans les autres cellules, il faudra d'abord veiller à transformer le dernier argument ([somme_plage)] en référence absolue. Pour cela, éditez la formule en appuyant sur F2, placez-vous sur B4 et appuyez sur F4. Répétez sur B26. Notre formule devient donc : =SOMME.SI(monTableau;D3;$B$4:$B$27).

Haut

Niveau

Pré-requis :

  • Aucun

 

 

Télécharger l'exemple - 15 ko

 

F2 éditer cellule
F4 basculer en référence relative/absolue